Not a fan of one of the genres?





(You can't hide all the genres)
 

Harderstate switches to https

For news, announcements, suggestions or other talk related to the site itself
  

Postby Lorenzo » 26 Nov 2018, 14:02

Harderstate has (finally :fist:) switched to SSL. That means that from now of on you will get all pages served via https.

The s in https stands for 'secure' and it provides a secure connection between your device and our server. Please note that this is only the connection! By using https, our site and your device have not suddenly become completely hacker-proof. However, it makes network attacks (like man in the middle) a lot harder.

Mixed content
The biggest practical problem with https is the concept 'mixed content'. With mixed content, 'unsafe' elements (like images) are loaded into a 'safe' page. In other words, there are elements from http servers in between.

The elements are still displayed by most browsers, although they were loaded unsafe. This is accompanied by an indication that the page is not securely protected. This problem will be tackled in the upcoming weeks, but in the meantime you can also do something yourself by checking/adjusting your signatures or post to links with https.

If you encounter a page with mixed content or any other error, you can report it here so I can fix it.

Cheers!
User avatar
Lorenzo (24)
Developer
 
Posts: 791
Location: Netherlands (nl)



Postby Qobalt » 26 Nov 2018, 14:34

Hi Lorenzo! Thanks for the news.
Just experienced a (new?) bug:
Open up any subforum (unreleased-hardstyle-f13/ for example)
Find a topic with 2 pages or more
Click on the page number <= 2
The parameter "start=20" (for example) is concatenated with '&' sign, should be '?' sign.

Actual
unreleased-hardstyle-f13/headhunterz-id-say-my-name-t48505.html&start=30
Expected
unreleased-hardstyle-f13/headhunterz-id-say-my-name-t48505.html?start=30
Image
User avatar
Qobalt (25)
State Celebrity
 
Posts: 1643
Location: Ukraine (ua) Kharkiv

Postby Bomberz » 26 Nov 2018, 16:00

harderstate.com doesn't redirect to https://harderstate.com I think :)
Image
User avatar
Bomberz (25)
Global Mod
 
Posts: 7444
Location: Spain (es)

Postby Lorenzo » 26 Nov 2018, 16:14

Qobalt:Hi Lorenzo! Thanks for the news.
Just experienced a (new?) bug:
Open up any subforum (unreleased-hardstyle-f13/ for example)
Find a topic with 2 pages or more
Click on the page number <= 2
The parameter "start=20" (for example) is concatenated with '&' sign, should be '?' sign.

Actual
unreleased-hardstyle-f13/headhunterz-id-say-my-name-t48505.html&start=30
Expected
unreleased-hardstyle-f13/headhunterz-id-say-my-name-t48505.html?start=30

I tried your steps but I can't reproduce it. Maybe it helps to clear your browser cache?

Bomberz:harderstate.com doesn't redirect to https://harderstate.com I think :)

Whoops I forgot to turn it back on :rofl: Should be fixed now!
User avatar
Lorenzo (24)
Developer
 
Posts: 791
Location: Netherlands (nl)

Postby Qobalt » 26 Nov 2018, 16:49

Lorenzo:I tried your steps but I can't reproduce it. Maybe it helps to clear your browser cache?

I cleared browser cache but the problem is still here. I think the screenshot will be more understandable :)



I use latest Google Chrome.

Edit:
actually click on the page number >= 2, not <= :)
Image
User avatar
Qobalt (25)
State Celebrity
 
Posts: 1643
Location: Ukraine (ua) Kharkiv

Postby Emre » 26 Nov 2018, 17:08

Thanks! Embedding seems to be bugged tho? I only get the URL :G
Emre (25)
State Retired Person
 
Posts: 16931
Location: Netherlands (nl)

Postby Morbid_Angel » 26 Nov 2018, 17:20

Image
This is what happens when I click on any page number before entering a topic. (For example, clicked on any of the 5 page numbers for the Phuture Noize release, and got this error, clicked on the topic itself and it read it just fine, and I could browse the pages)
Is this an error on my end, or a hiccup from the new https format?
Image
Image
Image
User avatar
Morbid_Angel (35)
State Native
 
Posts: 833
Location: Denmark (dk)

Postby Gracio » 26 Nov 2018, 17:22

Hard With Style in the radio and podcast section also buggy :+

Error 404 if you click on the last page
Image

FIFA World Cup Winner 2014: Germany
Harderstate World Cup Prediction Champion!!!
Gracio (31)
Crab
 
Posts: 9573
Location: Germany (de) Hamburg

Postby Bomberz » 26 Nov 2018, 17:38

Same problem for me in any topic.
Image
User avatar
Bomberz (25)
Global Mod
 
Posts: 7444
Location: Spain (es)

Postby Lorenzo » 26 Nov 2018, 17:53

Emre:Thanks! Embedding seems to be bugged tho? I only get the URL :G

What did you try to embed?

Qobalt:
Lorenzo:I tried your steps but I can't reproduce it. Maybe it helps to clear your browser cache?

I cleared browser cache but the problem is still here. I think the screenshot will be more understandable :)



I use latest Google Chrome.

Edit:
actually click on the page number >= 2, not <= :)

Morbid_Angel:
This is what happens when I click on any page number before entering a topic. (For example, clicked on any of the 5 page numbers for the Phuture Noize release, and got this error, clicked on the topic itself and it read it just fine, and I could browse the pages)
Is this an error on my end, or a hiccup from the new https format?

Gracio:Hard With Style in the radio and podcast section also buggy :+

Error 404 if you click on the last page

Bomberz:Same problem for me in any topic.

Ah I see. Basically all the same error. Thanks guys, I'll look into this.
User avatar
Lorenzo (24)
Developer
 
Posts: 791
Location: Netherlands (nl)

Postby Emre » 26 Nov 2018, 18:05

Lorenzo:
Emre:Thanks! Embedding seems to be bugged tho? I only get the URL :G

What did you try to embed?


A soundcloud rip:
Emre (25)
State Retired Person
 
Posts: 16931
Location: Netherlands (nl)

Postby RPGWiZaRD » 26 Nov 2018, 20:58

That explains why my AV keeps notifying me all the time when browsing this forum right now.

Image
RPGWiZaRD (32)
State Celebrity
 
Posts: 2154
Location: Finland (fi)

Postby Lorenzo » 27 Nov 2018, 12:14

Lorenzo:
Qobalt:
Lorenzo:I tried your steps but I can't reproduce it. Maybe it helps to clear your browser cache?

I cleared browser cache but the problem is still here. I think the screenshot will be more understandable :)



I use latest Google Chrome.

Edit:
actually click on the page number >= 2, not <= :)

Morbid_Angel:
This is what happens when I click on any page number before entering a topic. (For example, clicked on any of the 5 page numbers for the Phuture Noize release, and got this error, clicked on the topic itself and it read it just fine, and I could browse the pages)
Is this an error on my end, or a hiccup from the new https format?

Gracio:Hard With Style in the radio and podcast section also buggy :+

Error 404 if you click on the last page

Bomberz:Same problem for me in any topic.

Ah I see. Basically all the same error. Thanks guys, I'll look into this.

It's fixed. Thanks for letting me know :)

Emre:
Lorenzo:
Emre:Thanks! Embedding seems to be bugged tho? I only get the URL :G

What did you try to embed?


A soundcloud rip:

It's fixed. Thanks for letting me know :)

RPGWiZaRD:That explains why my AV keeps notifying me all the time when browsing this forum right now.


The blocked url comes from the signatures of Qobalt and Bomberz (the MYST user banner), but it has nothing to do with the ssl change (your anti virus is too sensitive because it's, most likely, a false positive)
User avatar
Lorenzo (24)
Developer
 
Posts: 791
Location: Netherlands (nl)

Postby Qobalt » 27 Nov 2018, 16:48

Thanks Lorenzo! Works for me now. :)
Image
User avatar
Qobalt (25)
State Celebrity
 
Posts: 1643
Location: Ukraine (ua) Kharkiv

Postby Malgranda » 27 Nov 2018, 16:55

Hats off to Lorenzo for getting this to work! :D
Image
Image
Image
User avatar
Malgranda (22)
Global Mod
 
Posts: 2299
Location: Netherlands (nl)



Quick Reply

Register or login to share your passion for the harder styles
   
 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 11 guests